Adobe took the unusual step of releasing an out of band patch to address a trio of serious security issues in Adobe Media Encoder.

The program is used by tens of thousands of people around the world to encode audio and video in a variety of formats.

The three issues addressed by this patch are being tracked as:

  • CVE-2020-9739
  • CVE-2020-9744
  • CVE-2020-9745

All three are out of bound read security flaws that could lead to contextual information about the current user being leaked. All three issues are rated as ‘Serious’ and impact version 14.4 of Media Encoder on both Mac and Windows-based machines.

There are a couple of points of interest here. First, these issues are rated ‘Serious,’ not critical, which makes it unusual that Adobe (or any company) would rush an out of band patch out the door to address them. Second, they’ve only been given a severity rating of 3, which generally denotes that the bugs aren’t a high priority or likely target for hackers to exploit, which only deepens the mystery.

Given the two facts above, it’s almost impossible not to speculate that something else must be going on behind the scenes. Unfortunately, we’re unlikely to learn the truth of that, even if there is some deeper issue or concern lurking in the minds of Adobe’s product managers.

In any event, if you use Adobe Media Encoder, you’ll probably want to take advantage of the out of band patch and upgrade at your next convenience. Just because the hackers haven’t made a target of these issues doesn’t mean they won’t start. If you’re unpatched, you’re vulnerable.

Kudos to Adobe for their unusually swift action here, and to independent security researcher Radu Motspan, who spotted them and reported them to the company.

Leave a Reply

Your email address will not be published. Required fields are marked *

error: Alert: Content is protected !!